Email Delivery Issue to Hotmail & Office365
Incident Report for Marsello
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 08:46 UTC
Identified
We have identified the issue and are actively working on implementing a solution. Your understanding and patience throughout this process are greatly appreciated.
Posted Feb 12, 2024 - 21:47 UTC
Investigating
We are actively investigating an issue where emails sent to Hotmail or Office365 are being routed incorrectly to the Junk folder. Deliverability is unaffected for other email providers (Gmail, Yahoo, etc). Our dedicated technical team is working diligently to resolve this matter swiftly. Rest assured, we will provide timely updates as progress is made. We appreciate your understanding and patience during this process.
Posted Feb 08, 2024 - 01:11 UTC
This incident affected: Marsello Marketing.