The issue affecting the Heartland has been resolved. Heartland services have stabilized, and requests are processing normally again. We will continue to monitor to ensure everything remains stable.
Posted Nov 28, 2025 - 19:02 UTC
Update
Heartland services have begun to stabilize, and we’re seeing successful requests coming through again. We are actively monitoring performance to ensure everything fully returns to normal.
Posted Nov 28, 2025 - 18:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2025 - 18:57 UTC
Identified
Our technical team has identified that App Insights is showing a spike in failed requests, which indicates that the server load was temporarily too high and caused timeouts.
Posted Nov 28, 2025 - 18:44 UTC
Update
We are continuing to investigate this issue.
Posted Nov 28, 2025 - 18:27 UTC
Investigating
We are currently investigating an issue where the Marsello loyalty widget is either not appearing in the Lightspeed (Heartland) POS interface or, when it does appear, clicking it results in a 502 Bad Gateway error.
Posted Nov 28, 2025 - 18:26 UTC
This incident affected: Marketing Loyalty and Marsello Integrations.