Email Deliverability - Domain Authentication Required
Incident Report for Marsello
Resolved
Emails are now being sent for unauthenticated domains. To prevent this from occurring in future please authenticate your sending domain https://help.marsello.com/en/articles/8138739-send-emails-from-your-custom-email-domain
Posted Apr 12, 2024 - 02:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 12, 2024 - 02:13 UTC
Monitoring
All emails that were on hold are now sending again as expected. 
To ensure no sending delays again for your account in the future, please authenticate your custom domain.

https://help.marsello.com/en/articles/8138739-send-emails-from-your-custom-email-domain
Posted Apr 11, 2024 - 23:03 UTC
Update
Due to the new regulations affected campaigns are currently on hold from being sent.
Posted Apr 11, 2024 - 23:02 UTC
Identified
New regulations now require domain authentication for accounts, and as a result, emails from unauthenticated accounts are not being sent.

https://help.marsello.com/en/articles/8802962-update-your-email-domain-settings-to-comply-with-the-new-google-yahoo-requirements
Posted Apr 11, 2024 - 19:48 UTC
This incident affected: Marketing Loyalty and Marsello Marketing.