Reporting data delay
Incident Report for Marsello
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 19:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 15, 2023 - 20:19 UTC
Investigating
We are experiencing a delay with the Marsello reporting pages. We have found the cause and are working to fix the problem and re-sync the data.
Posted Nov 15, 2023 - 20:19 UTC
This incident affected: Reporting.