Delays in Campaign Reporting
Incident Report for Marsello
Update
We’ve successfully identified the cause of the delay in campaign reporting and all data is synced and operational now. We apologize for any inconvenience caused.
Posted Jul 04, 2024 - 21:16 UTC
Investigating
We're experiencing a delay in campaign reporting, causing a backlog. We are currently investigating the root cause and are actively working on updating campaign reporting.

We apologize for any inconvenience caused and appreciate your patience as we work to restore normal operations.
Posted Jul 02, 2024 - 21:45 UTC
This incident affects: Marsello Marketing.